How to Configure?

Jul 12, 2011 at 1:12 PM
Edited Jul 12, 2011 at 1:13 PM

Hi,

I have installed this widget but I can't get it to work.

If I navigate to http://localhost/Admin/Uservoice.Widgets/Settings I am asked for

Account

The account name is the first part of your UserVoice URL. Example: myaccount

Host

 The host is the domain from your UserVoice URL. Example: myaccount.uservoice.com

ApiKey

You API key is aquired from the Settings panel on UserVoice. Create a new API Channel to receive your key.

 

So I navigate to

 

https:// myaccount.uservoice.com/admin/settings#/channels

 

I then scroll down to the section API, I add an API client, (I do not see an option to add a new API channel as suggested above.) After filling in the new API client form The API client settings are:

  • Key: kdjsisudkfeSDW28sw329
  • Secret: jksllsoisusjdjdjkfldkdrjffhgfjfjfjfkfkgkrkrkkdkd
  • Trusted: Yes
  • URL: myaccount.uservoice.com
  • Callback URL: myaccount.com/feedback
  • Request Token URL: https:// myaccount.uservoice.com/oauth/request_token
  • Access Token URL: https:// myaccount.uservoice.com/oauth/access_token
  • Authorize URL: https:// myaccount.uservoice.com/oauth/authorize

Now when I try to add a UserVoice feedback widget I get the following error.

Could not retrieve widgets list from UserVoice

Where am I going wrong?

I thank you in advance for any ideas you may have.

Best wishes

Austin

Hi,

I have installed this widget but I can't get it to work.

 

If I navigate to http://localhost/Admin/Uservoice.Widgets/Settings I am asked for

 

Account

The account name is the first part of your UserVoice URL. Example: myaccount

<label for="Host"> Host </label>

 The host is the domain from your UserVoice URL. Example: myaccount.uservoice.com

<label for="ApiKey"> ApiKey </label>

You API key is aquired from the Settings panel on UserVoice. Create a new API Channel to receive your key.

 

Could not retrieve widgets list from UserVo
Jul 13, 2011 at 4:50 PM

I did not receive a reply, so I've posted this question over on the main Orchard forums.

http://orchard.codeplex.com/discussions/265014

Hopefully someone over there can suggest a solution.

Cheers

Austin